tsites notes and tips

This is a quick note about sharing files between Windows 10 and Linux Mint.
(Something I had to do lately, and if this helps anyone else, I'll consider it a bonus).

Choose the folder in Windows you want to share.
Right-click it and choose 'Properties'
Click the 'Advanced Sharing...' button
In the next popup window, make sure 'Share this folder' is selected.
Now click 'Permissions'
In the next popup window that appears (yes, yet another one), click 'Add' if your username isn't listed and type your username in the next popup window. (For anyone counting this is the 4th popup window we need to navigate through).
Once you've done all that, make sure you press 'Apply' then 'Ok' to close the popups.

Now over to Linux:
(here I'm using Linux Mint, just because it has most of the stuff we already need. You could also use Ubuntu or any linux distro provided the SMB and samba dependencies are installed).

First, make sure you have 'cifs-utils' installed. 'Samba' wouldn't hurt to install either. Do this via 'Synaptic Package Manager'.
With those installed, we are almost ready to connect.

Last thing - you need to make a mount point (so Linux knows where to attach the share to).
Open terminal and run:

'su'

and enter your root password.

(if you never setup root, use:

sudo passwd root

and enter your password twice, then try the step above again).

mkdir /media/smbmounts

(makes the folder smbmounts in the media folder)

mkdir /media/smbmounts/tom

(makes the folder tom in the smbmounts folder)

Right, with that all done...

Here's an example connect command:

mount -t cifs //DESKTOP-U6IT0QS/tom -o username='tom',password='1234',vers='3.0',domain='WORKGROUP' /media/smbmounts/tom

'//DESKTOP-U6IT0QS' is the name of our networked computer and the '/tom' bit at the end is the name of our shared folder
the -o specifies options.
Our options are username='tom',password='1234' (pretty self explanatory)
The vers='3.0' part is the version of SMB we are using.
Current Windows servers do not support vers='1.0' protocol anymore, unless specifically configured in their registry to accept it. So by default, they reject connections from clients using the SMB1 protocol. Which leads to the misleading message "Host is down". (this is why I used vers='3.0') domain='WORKGROUP' is the domain or workgroup the computer belongs to. Default is normally 'WORKGROUP' in Windows by default
Lastly '/media/smbmounts/tom' is our mount point (Where we will attach the share from Windows into Linux).

We then have our SMB share with the name 'tom' pop onto the desktop.
Hopefully a picture tells a thousand words, so here's two of them:


Back to Forum Listing